diff mbox series

[bug#61250,1/3] gnu: Add r-viper.

Message ID 20230203121854.95308-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#61250,1/3] gnu: Add r-viper. | expand

Commit Message

nafkhamdc Feb. 3, 2023, 12:18 p.m. UTC
* gnu/packages/bioconductor.scm (r-viper): New variable.
---
 gnu/packages/bioconductor.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Ricardo Wurmus Feb. 3, 2023, 3:47 p.m. UTC | #1
Unfortunately, we cannot add this to Guix.   The license says:

  c. You agree that You will only use the Program and Documentation for
     non-commercial internal academic or educational research purposes
     only. You will not (i) reproduce or copy the Program (ii) use, or
     cause or permit the use of, the Program in whole or in part for any
     purpose other than as permitted under this License; (iii)
     distribute, sell, lease, license or otherwise make the Program
     available to a third party outside Your organization; or (iv)
     reverse engineer, decompile, or disassemble the Program.

I have instead added the package to guix-science-nonfree.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 711b988e7f..aeef6f4106 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8307,6 +8307,27 @@  (define-public r-variantannotation
 coding changes and predict coding outcomes.")
     (license license:artistic2.0)))
 
+(define-public r-viper
+  (package
+    (name "r-viper")
+    (version "1.32.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "viper" version))
+              (sha256
+               (base32
+                "11i2q9nakh534nx2l736id7k1yqhk7jpg32sbfl4vrnh398q86h6"))))
+    (properties `((upstream-name . "viper")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biobase r-e1071 r-kernsmooth r-mixtools))
+    (home-page "https://bioconductor.org/packages/viper")
+    (synopsis
+     "Virtual inference of protein-activity by enriched regulon analysis")
+    (description
+     "Inference of protein activity from gene expression data.
+Including the VIPER and msVIPER algorithms")
+    (license license:gpl2+)))
+
 (define-public r-vsn
   (package
     (name "r-vsn")