diff mbox series

[bug#61251,2/3] gnu: Add r-bcellviper.

Message ID 20230203121854.95308-2-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#61250,1/3] gnu: Add r-viper. | expand

Commit Message

nafkhamdc Feb. 3, 2023, 12:18 p.m. UTC
* gnu/packages/bioconductor.scm (r-bcellviper): New variable.
---
 gnu/packages/bioconductor.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ricardo Wurmus Feb. 3, 2023, 3:49 p.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index aeef6f4106..521d6c00be 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1248,6 +1248,29 @@  (define-public r-arrmdata
 from Illumina 450k methylation arrays.")
     (license license:artistic2.0)))
 
+(define-public r-bcellviper
+  (package
+    (name "r-bcellviper")
+    (version "1.34.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "bcellViper" version
+                                     'experiment))
+              (sha256
+               (base32
+                "1fpgh70x2r68v0ximgcdphnyzq2hgiwbamyhbac3yka8flhrd1fm"))))
+    (properties `((upstream-name . "bcellViper")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biobase))
+    (home-page "https://bioconductor.org/packages/bcellViper")
+    (synopsis
+     "Transcriptional interactome and normal human B-cell expression data")
+    (description
+     "This is a tool for human B-cell context-specific transcriptional regulatory network.
+In addition, this package provides a human normal B-cells dataset for
+the examples in package viper.")
+    (license license:gpl2+)))
+
 (define-public r-bladderbatch
   (package
     (name "r-bladderbatch")