diff mbox series

[bug#59835,3/3] gnu: Add r-harshlight.

Message ID 20221205152153.18545-3-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59835,1/3] gnu: Add r-makecdfenv. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 5, 2022, 3:21 p.m. UTC
* gnu/packages/bioconductor.scm (r-harshlight): New variable.
---
 gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 37b84983c4..346fccfd3a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5854,6 +5854,33 @@  (define-public r-gseabase
 Enrichment Analysis} (GSEA).")
     (license license:artistic2.0)))
 
+(define-public r-harshlight
+  (package
+    (name "r-harshlight")
+    (version "1.70.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "Harshlight" version))
+              (sha256
+               (base32
+                "0asjgcnwawg8x7ql0srhb2011rvb4kr2cpsa1cy28nfmjfvdf0qm"))))
+    (properties `((upstream-name . "Harshlight")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-affy
+           r-altcdfenvs
+           r-biobase))
+    (home-page "http://asterion.rockefeller.edu/Harshlight/")
+    (synopsis "Corrective make-up program for microarray chips")
+    (description
+     "The package detects extended diffuse and compact blemishes on microarray
+chips.  @code{Harshlight} marks the areas in a collection of chips (affybatch
+objects).  A corrected @code{AffyBatch} object will result.  The package replaces
+the defected areas with N/As or the median of the values of the same probe.  The
+new version handles the substitute value as a whole matrix to solve the memory
+problem.")
+    (license license:gpl2+)))
+
 (define-public r-hpar
   (package
     (name "r-hpar")