diff mbox series

[bug#59835,1/3] gnu: Add r-makecdfenv.

Message ID 20221205152153.18545-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59835,1/3] gnu: Add r-makecdfenv. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 5, 2022, 3:21 p.m. UTC
* gnu/packages/bioconductor.scm (r-makecdfenv): New variable.
---
 gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: b2a848d23d37f31496e1ff664f1dcf6abcdcc388

Comments

Ricardo Wurmus Dec. 12, 2022, 2:36 p.m. UTC | #1
I applied this series with minor changes, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..7cace3317c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6010,6 +6010,33 @@  (define-public r-made4
 datasets (coinertia analysis).")
     (license license:artistic2.0)))
 
+(define-public r-makecdfenv
+  (package
+    (name "r-makecdfenv")
+    (version "1.74.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "makecdfenv" version))
+              (sha256
+               (base32
+                "0bvj5dg6yfjnhga1z8788zmb98d8shyz8pzz0ggnml87c1p2gy25"))))
+    (properties `((upstream-name . "makecdfenv")))
+    (build-system r-build-system)
+    (inputs (list zlib))
+    (propagated-inputs
+     (list r-affy
+           r-affyio
+           r-biobase
+           r-zlibbioc))
+    (home-page "https://bioconductor.org/packages/makecdfenv")
+    (synopsis "Chip description file environment maker")
+    (description
+     "This package implements two functions.  One of them reads an @code{Affymetrix}
+@acronym{CDF, chip description file} and creates a hash table environment containing
+the location/probe set membership mapping.  The other one creates a package that
+automatically loads that environment.")
+    (license license:gpl2+)))
+
 (define-public r-metaneighbor
   (package
     (name "r-metaneighbor")