diff mbox series

[bug#59835,2/3] gnu: Add r-altcdfenvs.

Message ID 20221205152153.18545-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59835,1/3] gnu: Add r-makecdfenv. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 5, 2022, 3:21 p.m. UTC
* gnu/packages/bioconductor.scm (r-altcdfenvs): New variable.
---
 gnu/packages/bioconductor.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7cace3317c..37b84983c4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2492,6 +2492,37 @@  (define-public r-alpine
 data.")
     (license license:gpl2+)))
 
+(define-public r-altcdfenvs
+  (package
+    (name "r-altcdfenvs")
+    (version "2.60.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "altcdfenvs" version))
+              (sha256
+               (base32
+                "0fm4l93j6nm1w1w57zzryc1hkzapp8l16pkwjzdzllvwvsnsg8r0"))))
+    (properties `((upstream-name . "altcdfenvs")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-affy
+           r-biobase
+           r-biocgenerics
+           r-biostrings
+           r-hypergraph
+           r-makecdfenv
+           r-s4vectors))
+    (home-page "https://bioconductor.org/packages/altcdfenvs")
+    (synopsis
+     "Convenience data structures and functions to handle CDF environments")
+    (description
+     "The package is usable with @code{Affymetrix GeneChip} short oligonucleotide
+arrays, and it can be adapted or extended to other platforms.  It is able to
+modify or replace the grouping of probes in the probe sets.  Also, the package
+contains simple functions to read @code{R} connections in the @code{FASTA} format
+and it can create an alternative mapping from sequences.")
+    (license license:gpl2+)))
+
 (define-public r-aneufinder
   (package
     (name "r-aneufinder")