diff mbox series

[bug#59670,49/50] gnu: rust-which-4: Update to 4.3.0.

Message ID 20221129070104.8007-49-paren@disroot.org
State New
Headers show
Series gnu: zoxide: Update to 0.8.3. | expand

Commit Message

\( Nov. 29, 2022, 7:01 a.m. UTC
* gnu/packages/crates-io.scm (rust-which-4): Update to 4.3.0.
---
 gnu/packages/crates-io.scm | 35 ++++++++++++++++++-----------------
 1 file changed, 18 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fee3313544..d342566acb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -66303,27 +66303,28 @@  (define-public rust-wepoll-sys-stjepang-1
 (define-public rust-which-4
   (package
     (name "rust-which")
-    (version "4.2.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "which" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1nbsy9f5sn206jzby28if4m4s0m21n97mhk8qd703g3rya77l67a"))))
+    (version "4.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "which" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0yybp94wikf21vkcl8b6w6l5pnd95nl4fxryz669l4lyxsxiz0qw"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-either" ,rust-either-1)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-libc" ,rust-libc-0.2)
-        ("rust-regex" ,rust-regex-1))))
+     (list #:skip-build? #t
+           #:cargo-inputs
+           `(("rust-either" ,rust-either-1)
+             ("rust-libc" ,rust-libc-0.2)
+             ("rust-once-cell" ,rust-once-cell-1)
+             ("rust-regex" ,rust-regex-1))))
     (home-page "https://github.com/harryfei/which-rs.git")
-    (synopsis "Rust equivalent of Unix command @command{which}")
+    (synopsis "Rust equivalent of @command{which}")
     (description
-     "This package provides a Rust equivalent of Unix command @command{which}.
-It locates installed executable in cross platforms.")
+     "This package provides a cross-platform Rust equivalent of the
+Unix @command{which} command.  It returns the full path of an installed
+executable.")
     (license license:expat)))
 
 (define-public rust-which-3