* gnu/packages/crates-io.scm (rust-rstest-0.15): New variable.
(rust-rstest-0.10): Inherit from RUST-RSTEST-0.15.
(rust-rstest-0.6): Inherit from RUST-RSTEST-0.10.
---
gnu/packages/crates-io.scm | 84 ++++++++++++++++++++------------------
1 file changed, 45 insertions(+), 39 deletions(-)
@@ -46770,59 +46770,65 @@ (define-public rust-rstar-0.8
(base32
"1b6vjfwvpcgy0q8ywywz548vhxrmhbz2sm6xyhnmj5p5xd1xfqff"))))))
-(define-public rust-rstest-0.6
+(define-public rust-rstest-0.15
(package
(name "rust-rstest")
- (version "0.6.5")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "rstest" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1wdd0ci0bn6fd5v5c19lhlqrpadk18fl4jzvh75b26616anlxdil"))))
+ (version "0.15.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "rstest" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c5r8wimr2fv3x25dbb99rk165lzcsz6jlpv7xk2ny99rikdrjg9"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-cfg-if" ,rust-cfg-if-1)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quote" ,rust-quote-1)
- ("rust-rustc-version" ,rust-rustc-version-0.3)
- ("rust-syn" ,rust-syn-1))))
+ (list #:skip-build? #t
+ #:cargo-inputs
+ `(("rust-futures" ,rust-futures-0.3)
+ ("rust-futures-timer" ,rust-futures-timer-3)
+ ("rust-rstest-macros" ,rust-rstest-macros-0.14)
+ ("rust-rustc-version" ,rust-rustc-version-0.3))))
(home-page "https://github.com/la10736/rstest")
(synopsis "Rust fixture based test framework")
(description
- "rstest uses procedural macros to help you on writing fixtures and
-table-based tests.")
+ "@code{rstest} uses procedural macros to help you write fixtures
+and table-based tests.")
(license (list license:expat license:asl2.0))))
(define-public rust-rstest-0.10
(package
+ (inherit rust-rstest-0.15)
(name "rust-rstest")
(version "0.10.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "rstest" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1bwhy92fsqc05y8x9iyyq9sykinh0gxnl25zpdca3xhl5hhb06q4"))))
- (build-system cargo-build-system)
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "rstest" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bwhy92fsqc05y8x9iyyq9sykinh0gxnl25zpdca3xhl5hhb06q4"))))
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-cfg-if" ,rust-cfg-if-1)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quote" ,rust-quote-1)
- ("rust-rustc-version" ,rust-rustc-version-0.3)
- ("rust-syn" ,rust-syn-1))))
- (home-page "https://github.com/la10736/rstest")
- (synopsis "Rust fixture based test framework")
- (description
- "rstest uses procedural macros to help you on writing fixtures and
-table-based tests.")
- (license (list license:expat license:asl2.0))))
+ (list #:skip-build? #t
+ #:cargo-inputs
+ `(("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-rustc-version" ,rust-rustc-version-0.3)
+ ("rust-syn" ,rust-syn-1))))))
+
+(define-public rust-rstest-0.6
+ (package
+ (inherit rust-rstest-0.10)
+ (name "rust-rstest")
+ (version "0.6.5")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "rstest" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wdd0ci0bn6fd5v5c19lhlqrpadk18fl4jzvh75b26616anlxdil"))))))
(define-public rust-rstest-macros-0.14
(package