[bug#59670,44/50] gnu: rust-pathdiff-0.2: Update to 0.2.1.
Commit Message
* gnu/packages/crates-io.scm (rust-pathdiff-0.2): Update to 0.2.1.
---
gnu/packages/crates-io.scm | 28 +++++++++++++++-------------
1 file changed, 15 insertions(+), 13 deletions(-)
@@ -39181,23 +39181,25 @@ (define-public rust-path-clean-0.1
(define-public rust-pathdiff-0.2
(package
(name "rust-pathdiff")
- (version "0.2.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "pathdiff" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0d2aqgrqhdn5kxlnd5dxv7d6pgsgf92r6r9gqm6bdh0mvsrk0xl7"))))
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "pathdiff" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pa4dcmb7lwir4himg1mnl97a05b2z0svczg62l8940pbim12dc8"))))
(build-system cargo-build-system)
- (arguments `(#:skip-build? #t))
+ (arguments
+ (list #:skip-build? #t
+ #:cargo-inputs
+ `(("rust-camino" ,rust-camino-1))))
(home-page "https://github.com/Manishearth/pathdiff")
(synopsis "Library for diffing paths to obtain relative paths")
(description
- "Use diff_paths to construct a relative path from a provided base
-directory path to the provided path.")
+ "This package provides a Rust library for constructing a
+relative path from a provided base directory path to the provided
+path.")
(license (list license:asl2.0 license:expat))))
(define-public rust-pbkdf2-0.10