diff mbox series

[bug#59542,3/5] gnu: Add python-hvpy.

Message ID 20221124112441.22965-3-sharlatanus@gmail.com
State New
Headers show
Series gnu: Add python-sunpy. | expand

Commit Message

Sharlatan Hellseher Nov. 24, 2022, 11:24 a.m. UTC
* gnu/packages/astronomy.scm (python-hvpy): New variable.
---
 gnu/packages/astronomy.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 81a051b537..eb3b1f01b9 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1202,6 +1202,27 @@  (define-public python-ephem
 of dates.")
     (license license:expat)))
 
+(define-public python-hvpy
+  (package
+    (name "python-hvpy")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hvpy" version))
+       (sha256
+        (base32 "0r0asyflz2sw9zn5vgs138nh81m0rbwbakmrncbc1ghdr3g6jahv"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f)) ; Requires HTTP(S) access to api.beta.helioviewer.org
+    (propagated-inputs (list python-pydantic python-requests))
+    (native-inputs (list python-pytest python-pytest-astropy))
+    (home-page "https://helioviewer.org/")
+    (synopsis "Helioviewer Python API Wrapper")
+    (description "@code{hvpy} is a Python API wrapper around the formal @url{Helioviewer API,
+https://api.helioviewer.org/docs/v2/}.")
+    (license license:bsd-2)))
+
 (define-public python-mpl-animators
   (package
     (name "python-mpl-animators")