diff mbox series

[bug#59542,2/5] gnu: Add python-mpl-animators.

Message ID 20221124112441.22965-2-sharlatanus@gmail.com
State New
Headers show
Series gnu: Add python-sunpy. | expand

Commit Message

Sharlatan Hellseher Nov. 24, 2022, 11:24 a.m. UTC
* gnu/packages/astronomy.scm (python-mpl-animators): New variable.
---
 gnu/packages/astronomy.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4ae2e1caa2..81a051b537 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1202,6 +1202,32 @@  (define-public python-ephem
 of dates.")
     (license license:expat)))
 
+(define-public python-mpl-animators
+  (package
+    (name "python-mpl-animators")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mpl_animators" version))
+       (sha256
+        (base32 "12kjmj7rn3pk9ly82h5s5hn0kl3kxkr7bgkz9zr9k59pir8z1r8b"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-pytest
+           python-pytest-mpl
+           python-setuptools-scm))
+    (propagated-inputs
+     (list python-astropy
+           python-matplotlib
+           python-numpy))
+    (home-page "https://sunpy.org")
+    (synopsis "Interactive animations with matplotlib")
+    (description
+     "The @code{mpl_animators} package provides a set of classes which allow the
+easy construction of interactive matplotlib widget based animations.")
+    (license license:bsd-3)))
+
 (define-public python-photutils
   (package
     (name "python-photutils")