diff mbox series

[bug#59542,1/5] gnu: Add python-drms.

Message ID 20221124112441.22965-1-sharlatanus@gmail.com
State New
Headers show
Series gnu: Add python-sunpy. | expand

Commit Message

Sharlatan Hellseher Nov. 24, 2022, 11:24 a.m. UTC
* gnu/packages/astronomy.scm (python-drms): New variable.
---
 gnu/packages/astronomy.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d450d1dd94..4ae2e1caa2 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1142,6 +1142,43 @@  (define-public python-cdflib
 @end itemize")
     (license license:expat)))
 
+(define-public python-drms
+  (package
+    (name "python-drms")
+    (version "0.6.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "drms" version))
+       (sha256
+        (base32 "1b0w350y4wbgyy19zcf28xbb85mqq6gnhb6ppibbc4hbn2ixbcvj"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key inputs outputs tests?
+                      #:allow-other-keys)
+              (when tests?
+                (add-installed-pythonpath inputs outputs)
+                (setenv "JSOC_EMAIL" "jsoc@sunpy.org")
+                (invoke "python" "-m" "pytest" "-vv")))))))
+    (native-inputs
+     (list python-astropy
+           python-pytest-astropy
+           python-pytest
+           python-setuptools-scm))
+    (propagated-inputs (list python-numpy python-pandas))
+    (home-page "https://sunpy.org")
+    (synopsis "Access astronomical HMI, AIA and MDI data with Python")
+    (description
+     "DRMS module provides an easy-to-use interface for accessing HMI, AIA and MDI
+data with Python.  It uses the publicly accessible
+JSOC (@url{http://jsoc.stanford.edu/}) DRMS server by default, but can also be
+used with local NetDRMS sites.")
+    (license license:bsd-2)))
+
 (define-public python-ephem
   (package
     (name "python-ephem")