@@ -17028,12 +17028,11 @@ (define-public python-cattrs
(sha256
(base32
"1n0h25gj6zd02kqyl040xpdvg4hpy1j92716sz0rg019xjqqijqb"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- ;; XXX: PEP 517 manual build copied from python-isort.
(add-after 'unpack 'adjust-for-older-attrs
;; Our older attrs package is using the 'attr' rather than 'attrs'
;; namespace.
@@ -17042,14 +17041,6 @@ (define-public python-cattrs
(substitute* (find-files "." "\\.py$")
(("from attrs\\b")
"from attr"))))
- (replace 'build
- (lambda _
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
@@ -17067,7 +17058,6 @@ (define-public python-cattrs
python-msgpack
python-poetry-core
python-pymongo ;for the bson module
- python-pypa-build
python-pytest
python-pytest-xdist))
(propagated-inputs