diff mbox series

[bug#58587,v3,07/22] gnu: flair: Switch to pyproject-build-system.

Message ID 20221022222100.18103-7-marius@gnu.org
State New
Headers show
Series [bug#58587,v3,01/22] gnu: python-setuptools: Move to python-build. | expand

Commit Message

Marius Bakke Oct. 22, 2022, 10:20 p.m. UTC
* gnu/packages/bioinformatics.scm (flair)[build-system]: Switch to
PYPROJECT-BUILD-SYSTEM.
[arguments]: Remove #:phases.
[native-inputs]: Remove.
---
 gnu/packages/bioinformatics.scm | 23 +++--------------------
 1 file changed, 3 insertions(+), 20 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f2de09aa32..3588f4e3fd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -56,6 +56,7 @@  (define-module (gnu packages bioinformatics)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system ocaml)
   #:use-module (guix build-system perl)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
   #:use-module (guix build-system qt)
   #:use-module (guix build-system r)
@@ -16928,33 +16929,15 @@  (define-public flair
        (sha256
         (base32
          "106swb2q7l20ki58fca1hg95q5f79bgp9gjb0clr2243ycrzyxf8"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     (list
-      #:tests? #false ;there are none
-      #:phases
-      #~(modify-phases %standard-phases
-          ;; TODO: implement as a feature of python-build-system (PEP-621,
-          ;; PEP-631, PEP-660)
-          (replace 'build
-            (lambda _
-              (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)
-              ;; ZIP does not support timestamps before 1980.
-              (setenv "SOURCE_DATE_EPOCH" "315532800")
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
-          (replace 'install
-            (lambda _
-              (apply invoke "pip" "--no-cache-dir" "--no-input"
-                     "install" "--no-deps" "--prefix" #$output
-                     (find-files "dist" "\\.whl$")))))))
+     (list #:tests? #false)) ;there are none
     (propagated-inputs
      (list python-mappy
            python-ncls
            python-pybedtools
            python-pysam
            python-tqdm))
-    (native-inputs
-     (list python-pypa-build python-setuptools))
     (home-page "https://flair.readthedocs.io/en/latest/")
     (synopsis "Full-length alternative isoform analysis of RNA")
     (description "This package implements FLAIR (Full-Length Alternative