diff mbox series

[bug#58587,v3,21/22] gnu: python-scikit-build: Switch to pyproject-build-system.

Message ID 20221022222100.18103-21-marius@gnu.org
State New
Headers show
Series [bug#58587,v3,01/22] gnu: python-setuptools: Move to python-build. | expand

Commit Message

Marius Bakke Oct. 22, 2022, 10:20 p.m. UTC
* gnu/packages/python-xyz.scm (python-scikit-build)[build-system]: Set to
PYPROJECT-BUILD-SYSTEM.
[arguments]: Remove obsolete phases.
[native-inputs]: Remove PYTHON-PYPA-BUILD and PYTHON-WHEEL.
---
 gnu/packages/python-xyz.scm | 18 +++---------------
 1 file changed, 3 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a8b94b0acb..bae4c385c0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27859,7 +27859,7 @@  (define-public python-scikit-build
        (uri (pypi-uri "scikit-build" version))
        (sha256
         (base32 "1wx1m9vnxnnz59lyaisgyxldp313kciyd4af8lf112vb8vbjy9yk"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
       #:phases
@@ -27870,11 +27870,6 @@  (define-public python-scikit-build
                 (("^(CMAKE_DEFAULT_EXECUTABLE = ).*" _ head)
                  (format #f "~a ~s~%" head
                          (search-input-file inputs "bin/cmake"))))))
-          ;; XXX: PEP 517 manual build copied from python-isort.
-          (replace 'build
-            (lambda _
-              (setenv "SOURCE_DATE_EPOCH" "315532800")
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
@@ -27900,12 +27895,7 @@  (define-public python-scikit-build
                               ;; nondeterministically (see:
                               ;; https://github.com/scikit-build/scikit-build/issues/711).
                               "and not test_generator_cleanup "
-                              "and not test_generator_selection ")))))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl)))))))
+                              "and not test_generator_selection "))))))))
     (native-inputs
      (list cmake-minimal
            gfortran
@@ -27916,15 +27906,13 @@  (define-public python-scikit-build
            python-mock
            python-packaging
            python-path
-           python-pypa-build
            python-pytest
            python-pytest-cov
            python-pytest-mock
            python-pytest-virtualenv
            python-pytest-xdist
            python-requests
-           python-setuptools-scm
-           python-wheel))
+           python-setuptools-scm))
     (propagated-inputs
      (list python-distro python-packaging python-wheel))
     (home-page "https://github.com/scikit-build/scikit-build")