diff mbox series

[bug#58437,4/4] gnu: python-trezor-agent: Update to 0.14.5.

Message ID 20221011131243.28391-4-attila@lendvai.name
State New
Headers show
Series [bug#58437,1/4] gnu: Add python-simple-rlp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai Oct. 11, 2022, 1:12 p.m. UTC
---
 gnu/packages/finance.scm | 18 ++++++++++++------
 1 file changed, 12 insertions(+), 6 deletions(-)

Comments

Christopher Baines Dec. 6, 2022, 11:18 a.m. UTC | #1
Hi Attila,

Apologies it's taken so long to look at these patches.

I've gone ahead and pushed the two patches adding new packages.

I had a look at the changes to the trezor related packages. I wonder if
python-simple-rlp should be a propagated input for any packages? That
might avoid specifying it as an input to trezor-agent.

Also, it would be good to have any changes to trezor-agent in a separate
commit if they're needed.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 22b6855519..f9dab9c16c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -922,7 +922,7 @@  (define-public python-trezor-agent
   ;; the toplevel app called trezor-agent.
   (package
     (name "python-trezor-agent")
-    (version "0.14.4")
+    (version "0.14.5")
     (source
      (origin
        (method git-fetch)
@@ -931,7 +931,7 @@  (define-public python-trezor-agent
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1ksv494xpga27ifrjyn1bkqaya5h769lqb9rx1ng0n4kvmnrqr3l"))))
+        (base32 "1syg5an5hj8sr56hvcr45y8dymwy8va5h0pfyrmsnxcz8z5q1124"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -959,8 +959,12 @@  (define-public python-trezor-agent
            python-semver
            python-unidecode
            python-wheel))
-    (native-inputs
-     (list gnupg python-mock python-pytest))
+    (native-inputs ; Only needed for running the tests
+     (list gnupg
+           python-bech32
+           python-cryptography
+           python-mock
+           python-pytest))
     (home-page "https://github.com/romanz/trezor-agent")
     (synopsis "Use hardware wallets as SSH and GPG agent")
     (description
@@ -1243,8 +1247,10 @@  (define-public trezor-agent
     (build-system python-build-system)
     (inputs
      (list python-trezor python-trezor-agent))
-    (native-inputs
-     (list python-attrs))
+    (native-inputs ; Only needed for running the tests
+     (list python-attrs
+           python-bech32
+           python-simple-rlp))
     (home-page "https://github.com/romanz/trezor-agent")
     (synopsis "Using Trezor as hardware SSH/GPG agent")
     (description "This package allows using Trezor as a hardware SSH/GPG