diff mbox series

[bug#58437,2/4] gnu: python-trezor: Update to 0.13.3.

Message ID 20221011131243.28391-2-attila@lendvai.name
State New
Headers show
Series [bug#58437,1/4] gnu: Add python-simple-rlp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai Oct. 11, 2022, 1:12 p.m. UTC
Also disable the sanity-check phase.
---
 gnu/packages/finance.scm | 19 ++++++++++++-------
 1 file changed, 12 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index ac19851a85..340e56036d 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1048,7 +1048,7 @@  (define-public python-btchip-python
 (define-public python-trezor
   (package
     (name "python-trezor")
-    (version "0.13.0")
+    (version "0.13.3")
     (source
      (origin
        (method git-fetch)
@@ -1057,7 +1057,7 @@  (define-public python-trezor
              (commit (string-append "python/v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1wy584bxx5p2av4lv1bx9hl1q0b5n7hqz0hnqb9shjriarvl5ckd"))
+        (base32 "18qbdypi780b2s933dp7msh9m17mx9nq6qxn87jkwlf4i94h1vr2"))
        (modules
         '((guix build utils)
           (srfi srfi-26)
@@ -1083,10 +1083,7 @@  (define-public python-trezor
     (build-system python-build-system)
     (propagated-inputs
      (list python-attrs
-           ;; TOOD: Use the latest click version after release 0.13.1 or later
-           ;; is made (see:
-           ;; https://github.com/trezor/trezor-firmware/issues/2199).
-           python-click-7
+           python-click
            python-construct
            python-ecdsa
            python-hidapi
@@ -1099,9 +1096,17 @@  (define-public python-trezor
      (list protobuf
            python-black
            python-isort
+           python-pillow
            python-protobuf
            python-pyqt
-           python-pytest))
+           python-pytest
+           python-simple-rlp))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; This package only has a Python script, not a Python module, so the
+         ;; sanity-check phase can't work.
+         (delete 'sanity-check))))
     (home-page "https://github.com/trezor/python-trezor")
     (synopsis "Python library for communicating with TREZOR Hardware Wallet")
     (description "@code{trezor} is a Python library for communicating with