diff mbox series

[bug#58437,1/4] gnu: Add python-simple-rlp.

Message ID 20221011131002.28153-1-attila@lendvai.name
State New
Headers show
Series [bug#58437,1/4] gnu: Add python-simple-rlp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai Oct. 11, 2022, 1:10 p.m. UTC
* gnu/packages/python-xyz.scm (python-simple-rlp): New variable
---
this patch series updates the trezor tools.

does not fix https://issues.guix.gnu.org/55802

 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Attila Lendvai Aug. 26, 2023, 9:36 p.m. UTC | #1
close 58437
done

meanwhile it's been superseded by https://issues.guix.gnu.org/65037 that updates the packages to even newer versions.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c369362dc7..f038e912db 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2850,6 +2850,30 @@  (define-public python-simplejson
 Python 3.3+.")
     (license license:x11)))
 
+(define-public python-simple-rlp
+  (package
+    (name "python-simple-rlp")
+    (version "0.1.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/SamuelHaidu/simple-rlp")
+             ;; Upstream doesn't tag the git repo.
+             (commit "342ea269d84da1ddc4a7630cdebc90159261391c")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1nv92sphpkyrncak4qgj50qmgkmj4ycl2szbnv9c7ihgl5df4div"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/SamuelHaidu/simple-rlp")
+    (synopsis
+     "Python implementation of RLP (Recursive Length Prefix encoding)")
+    (description
+     "@code{simple-rlp} is a python implementation of RLP (Recursive Length \
+Prefix) - Encode and decode data structures.")
+    ;; TODO not vanilla MIT: https://github.com/SamuelHaidu/simple-rlp/issues/1
+    (license license:expat)))
 
 (define-public python-pyicu
   (package