@@ -9966,3 +9966,29 @@ (define-public go-github-com-xo-terminfo
(description
"The terminfo package implements terminfo database reading for Go.")
(license license:expat)))
+
+(define-public go-github-com-riywo-loginshell
+ (package
+ (name "go-github-com-riywo-loginshell")
+ (version "0.0.0-20200815045211-7d26008be1ab")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/riywo/loginshell")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "138yvis6lipw9x02jyiz7472bxi20206bcfikcar54i3xsww9q4i"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/riywo/loginshell"
+ ;; Tests try to get the current user's login shell; the build
+ ;; user doesn't have one.
+ #:tests? #f))
+ (home-page "https://github.com/riywo/loginshell")
+ (synopsis "Get the user's login shell in Go")
+ (description
+ "The loginshell package provides a Go library to get the login shell
+of the current user.")
+ (license license:expat)))
From: "(unmatched-parenthesis" <paren@disroot.org> * gnu/packages/golang.scm (go-github-com-riywo-loginshell): New variable. --- gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++ 1 file changed, 26 insertions(+)