diff mbox series

[bug#55903,v3,29/35] gnu: Add go-git-sr-ht--sircmpwn-getopt.

Message ID 20220613194030.3540-29-paren@disroot.org
State New
Headers show
Series [bug#55903,v3,01/35] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 13, 2022, 7:40 p.m. UTC
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-git-sr-ht--sircmpwn-getopt): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b39790964c..46e45a1ba8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10591,3 +10591,27 @@  (define-public go-github-com-arran4-golang-ical
     (description
      "The ical package provides an ICS/iCalender parser and serialiser for Go.")
     (license license:asl2.0)))
+
+(define-public go-git-sr-ht--sircmpwn-getopt
+  (package
+    (name "go-git-sr-ht--sircmpwn-getopt")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~sircmpwn/getopt")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0f9rammnmhaz21qkmz7qf76r8jlzi323g05ps3j7gwrxlw7442a6"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "git.sr.ht/~sircmpwn/getopt"))
+    (propagated-inputs (list go-github-com-stretchr-testify))
+    (home-page "https://git.sr.ht/~sircmpwn/getopt")
+    (synopsis "POSIX getopt for Go")
+    (description
+     "The getopt package is a POSIX-compatible implementation of getopt(3)
+for Go.")
+    (license license:bsd-3)))