diff mbox series

[bug#55903,v3,30/35] gnu: Add go-github-com-lithammer-fuzzysearch.

Message ID 20220613194030.3540-30-paren@disroot.org
State New
Headers show
Series [bug#55903,v3,01/35] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 13, 2022, 7:40 p.m. UTC
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-lithammer-fuzzysearch): New
  variable.
---
 gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 46e45a1ba8..9dfe9f0914 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10615,3 +10615,32 @@  (define-public go-git-sr-ht--sircmpwn-getopt
      "The getopt package is a POSIX-compatible implementation of getopt(3)
 for Go.")
     (license license:bsd-3)))
+
+(define-public go-github-com-lithammer-fuzzysearch
+  (package
+    (name "go-github-com-lithammer-fuzzysearch")
+    (version "1.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/lithammer/fuzzysearch")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "095zw3ffkp1w1lz4gby92b7vgi9zfvqc2s3rkl166a4narhv85fg"))))
+    (build-system go-build-system)
+    (propagated-inputs (list go-golang-org-x-text))
+    (arguments
+     (list #:import-path "github.com/lithammer/fuzzysearch"
+           #:tests? #f ; Source-only package.
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; Source-only package.
+               (delete 'build))))
+    (home-page "https://github.com/lithammer/fuzzysearch")
+    (synopsis "Tiny and fast fuzzy search in Go")
+    (description
+     "A speedy fuzzy matching package for Go inspired by the JavaScript
+library bevacqua/fuzzysearch.")
+    (license license:expat)))