@@ -10477,3 +10477,32 @@ (define-public go-github-com-protonmail-go-crypto
is completely backwards compatible with
@url{golang.org/x/crypto,the official package}.")
(license license:bsd-3)))
+
+(define-public go-github-com-emersion-go-pgpmail
+ (package
+ (name "go-github-com-emersion-go-pgpmail")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-pgpmail")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ar26b0apw5bxn58qfn1a79cxigbmrqm1irh1rb7x57fydihc7wm"))))
+ (build-system go-build-system)
+ (arguments
+ (list ;; tests don't support our version of protonmail/go-crypto; see
+ ;; <https://github.com/emersion/go-pgpmail/issues/12>
+ #:tests? #f
+ #:import-path "github.com/emersion/go-pgpmail"))
+ (propagated-inputs (list go-golang-org-x-text
+ go-golang-org-x-crypto
+ go-github-com-emersion-go-message
+ go-github-com-protonmail-go-crypto))
+ (home-page "https://github.com/emersion/go-pgpmail")
+ (synopsis "PGP mail encryption for Go")
+ (description
+ "The pgpmail package implements PGP encryption for e-mail messages.")
+ (license license:expat)))
From: "(unmatched-parenthesis" <paren@disroot.org> * gnu/packages/golang.scm (go-github-com-emersion-go-pgpmail): New variable. --- gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++ 1 file changed, 29 insertions(+)