@@ -10212,3 +10212,27 @@ (define-public go-github-com-jaytaylor-html2text
"The html2text package converts HTML emails to plain text, allowing
text-only mail clients to display them.")
(license license:expat)))
+
+(define-public go-github-com-go-test-deep
+ (package
+ (name "go-github-com-go-test-deep")
+ (version "1.0.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-test/deep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mmw2w3by7y24jjpjwmf2gfl08c65jihn3si9m0sswmagmdsk8q0"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/go-test/deep"))
+ (home-page "https://github.com/go-test/deep")
+ (synopsis "Human-friendly deep variable equality in Go")
+ (description
+ "The deep package provides the deep.Equal function which is like
+reflect.DeepEqual but returns a list of differences. This is helpful
+when comparing complex types like structures and maps.")
+ (license license:expat)))
From: "(unmatched-parenthesis" <paren@disroot.org> * gnu/packages/golang.scm (go-github-com-go-test-deep): New variable. --- gnu/packages/golang.scm | 24 ++++++++++++++++++++++++ 1 file changed, 24 insertions(+)