@@ -10109,3 +10109,33 @@ (define-public go-github-com-rivo-uniseg
split strings in their intended places, or to extract individual characters
which form a unit.")
(license license:expat)))
+
+(define-public go-github-com-rivo-tview
+ (package
+ (name "go-github-com-rivo-tview")
+ (version "0.0.0-20220307222120-9994674d60a8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rivo/tview")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0594ishcsd582apbz8jvhz8dg5i7nvyl3k6b6bzprf3z5kmsy9vk"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/rivo/tview"))
+ (propagated-inputs (list go-golang-org-x-term
+ go-golang-org-x-sys
+ go-github-com-rivo-uniseg
+ go-github-com-mattn-go-runewidth
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-gdamore-tcell-v2))
+ (home-page "https://github.com/rivo/tview")
+ (synopsis "Rich Interactive Widgets for Terminal UIs")
+ (description
+ "The tview package implements rich widgets for terminal based user
+interfaces. The widgets provided with this package are useful for data
+exploration and data entry.")
+ (license license:expat)))
From: "(unmatched-parenthesis" <paren@disroot.org> * gnu/packages/golang.scm (go-github-com-rivo-tview): New variable. --- gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++ 1 file changed, 30 insertions(+)