@@ -34,6 +34,7 @@
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
+;;; Copyright © 2022 (unmatched parenthesis <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,6 +70,7 @@ (define-module (gnu packages golang)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages mail)
#:use-module (gnu packages mp3)
#:use-module (gnu packages password-utils)
#:use-module (gnu packages pcre)
@@ -9834,3 +9836,30 @@ (define-public go-github-com-google-go-jsonnet
production-ready implementation, compatible with the original Jsonnet C++
implementation.")
(license license:asl2.0)))
+
+(define-public go-github-com-zenhack-go-notmuch
+ (package
+ (name "go-github-com-zenhack-go-notmuch")
+ (version "0.0.0-20211022191430-4d57e8ad2a8b")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zenhack/go.notmuch")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j2s5smjf7pp7i72dw12sm9iz961y3cy8nkm7hmrg53f6wna57h9"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/zenhack/go.notmuch"
+ ;; XXX: Tests require you to download fixtures from the Internet.
+ ;; See <https://github.com/zenhack/go.notmuch/blob/master/Makefile>.
+ #:tests? #f))
+ (propagated-inputs (list notmuch))
+ (home-page "https://github.com/zenhack/go.notmuch")
+ (synopsis "Go bindings to libnotmuch")
+ (description
+ "The notmuch package provides a Go language binding to the notmuch
+email library.")
+ (license license:gpl3+)))
From: "(unmatched-parenthesis" <paren@disroot.org> * gnu/packages/golang.scm (go-github-com-zenhack-go-notmuch): New variable. --- gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++ 1 file changed, 29 insertions(+)