diff mbox series

[bug#55170,4/5] gnu: dealii: Add SUNDIALS dependency.

Message ID 20220428181919.281837-4-paul@apatience.com
State Accepted
Headers show
Series gnu: dealii: Add SUNDIALS dependency and update to 9.3.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 28, 2022, 6:19 p.m. UTC
* gnu/packages/maths.scm (dealii)[propagated-inputs]: Add sundials-5.
Reformat list to clarify comment.
(dealii-openmpi)[propagated-inputs]: Add sundials-openmpi-5.
---
 gnu/packages/maths.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e6ebada82b..c74f055a07 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5205,7 +5205,11 @@  (define-public dealii
      ;; Anyway, they are meant to be used at build time, so rather than adding
      ;; the interpreters here, any package depending on them should just add
      ;; the requisite interpreter to its native inputs.
-     (list boost hdf5 suitesparse ; For UMFPACK.
+     (list boost
+           hdf5
+           suitesparse                  ; For UMFPACK.
+           ;; SUNDIALS 6.0.0 and later will be supported in deal.II 9.4.0.
+           sundials-5
            tbb))
     (arguments
      `(#:build-type "DebugRelease" ; Supports only Debug, Release and DebugRelease.
@@ -5255,12 +5259,13 @@  (define-public dealii-openmpi
                 scalapack)))
     (propagated-inputs
      (modify-inputs (package-propagated-inputs dealii)
-       (delete "hdf5")
+       (delete "hdf5" "sundials")
        (prepend hdf5-parallel-openmpi
                 openmpi
                 p4est-openmpi
                 petsc-openmpi
                 slepc-openmpi
+                sundials-openmpi-5
                 trilinos-for-dealii-openmpi)))
     (arguments
      (substitute-keyword-arguments (package-arguments dealii)