diff mbox series

[bug#55170,2/5] gnu: dealii: Remove trailing booleans.

Message ID 20220428181919.281837-2-paul@apatience.com
State Accepted
Headers show
Series gnu: dealii: Add SUNDIALS dependency and update to 9.3.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 28, 2022, 6:19 p.m. UTC
* gnu/packages/maths.scm (dealii)[snippet]: Remove trailing boolean (and
therefore the 'begin').
[native-inputs, inputs]: Reindent.
[arguments]<#:phases>: Remove trailing boolean.
---
 gnu/packages/maths.scm | 23 ++++++++++-------------
 1 file changed, 10 insertions(+), 13 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index dbb9bf1cf3..3c96378a4e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5183,22 +5183,20 @@  (define-public dealii
                                 "dealii-fix-sundials.patch"))
        (modules '((guix build utils)))
        (snippet
-        '(begin
-           ;; Remove bundled boost, muparser, TBB and UMFPACK.
-           (delete-file-recursively "bundled")
-           #t))))
+        ;; Remove bundled boost, muparser, TBB and UMFPACK.
+        '(delete-file-recursively "bundled"))))
     (build-system cmake-build-system)
     (outputs '("out" "doc"))
     (native-inputs
      ;; Required to build the documentation.
-      (list graphviz doxygen perl))
+     (list graphviz doxygen perl))
     (inputs
-      (list arpack-ng
-            openblas
-            gfortran
-            lapack
-            muparser
-            zlib))
+     (list arpack-ng
+           openblas
+           gfortran
+           lapack
+           muparser
+           zlib))
     (propagated-inputs
      ;; Some scripts are installed into share/deal.II/scripts that require
      ;; perl and python, but they are not executable (and some are missing the
@@ -5235,8 +5233,7 @@  (define-public dealii
              (let ((doc (string-append (assoc-ref outputs "doc")
                                        "/share/doc/" ,name "-" ,version)))
                (for-each delete-file (map (lambda (f) (string-append doc "/" f))
-                                          '("detailed.log" "summary.log"))))
-             #t)))))
+                                          '("detailed.log" "summary.log")))))))))
     (home-page "https://www.dealii.org/")
     (synopsis "Finite element library")
     (description