diff mbox series

[bug#50537,v2,03/27] gnu: Add ruby-countdownlatch.

Message ID 20220427184633.94169-3-singpolyma@singpolyma.net
State Accepted
Headers show
Series [bug#50537,v2,01/27] gnu: Add ruby-sucker-punch | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber April 27, 2022, 6:46 p.m. UTC
* gnu/packages/ruby.scm (ruby-countdownlatch): New variable.
---
 gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6547a2d35d..70f3477ccb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12283,3 +12283,25 @@  floating-point numbers or complex numbers as arguments.")
     (home-page
       "https://github.com/benlangfeld/Niceogiri")
     (license license:expat)))
+
+(define-public ruby-countdownlatch
+  (package
+    (name "ruby-countdownlatch")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "countdownlatch" version))
+        (sha256
+          (base32
+            "1v6pbay6z07fp7yvnba1hmyacbicvmjndd8rn2h1b5rmpcb5s0j3"))))
+    (build-system ruby-build-system)
+    (synopsis
+      "Synchronization aid allowing threads to wait for operations in other threads")
+    (description
+      "This package provides a synchronization aid that allows one or more
+threads to wait until a set of operations being performed in other threads
+completes")
+    (home-page
+      "https://github.com/benlangfeld/countdownlatch")
+    (license license:expat)))