diff mbox series

[bug#50537,v2,23/27] gnu: Add ruby-sentry-core

Message ID 20220427184633.94169-23-singpolyma@singpolyma.net
State Accepted
Headers show
Series [bug#50537,v2,01/27] gnu: Add ruby-sucker-punch | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber April 27, 2022, 6:46 p.m. UTC
* gnu/packages/ruby.scm (ruby-sentry-core): New variable.
---
 gnu/packages/ruby.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3a67480e33..aecf5499d2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12833,3 +12833,30 @@  published rates from open-exchange-rates.  Compatible with the money gem.")
     (home-page
       "https://github.com/Bandwidth/ruby-bandwidth-iris")
     (license license:expat)))
+
+(define-public ruby-sentry-core
+  (package
+    (name "ruby-sentry-core")
+    (version "4.3.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "sentry-ruby-core" version))
+        (sha256
+          (base32
+            "13z35s9mflh3v775a0scsnqhscz9q46kaak38y7zmx32z7sg2a3a"))))
+    (build-system ruby-build-system)
+    (arguments
+     ; No rakefile in gem
+     '(#:tests? #f))
+    (propagated-inputs
+      `(("ruby-concurrent" ,ruby-concurrent)
+        ("ruby-faraday" ,ruby-faraday)))
+    (synopsis
+      "Client interface for the Sentry error logger (core)")
+    (description
+      "This package provides a gem that provides a client interface for the
+Sentry error logger")
+    (home-page
+      "https://github.com/getsentry/sentry-ruby")
+    (license license:expat)))