diff mbox series

[bug#50537,v2,27/27] gnu: Add ruby-pry-rescue.

Message ID 20220427184633.94169-27-singpolyma@singpolyma.net
State Accepted
Headers show
Series [bug#50537,v2,01/27] gnu: Add ruby-sucker-punch | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber April 27, 2022, 6:46 p.m. UTC
* gnu/packages/ruby.scm (ruby-pry-rescue): New variable.
---
 gnu/packages/ruby.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6afc07875b..5a5665f027 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12931,3 +12931,38 @@  exceptions as they are raised.")
     (home-page
       "https://github.com/ConradIrwin/interception")
     (license license:expat)))
+
+(define-public ruby-pry-rescue
+  (package
+    (name "ruby-pry-rescue")
+    (version "1.5.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "pry-rescue" version))
+        (sha256
+          (base32
+            "1wn72y8y3d3g0ng350ld92nyjln012432q2z2iy9lhwzjc4dwi65"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'nuke-bad-test
+           (lambda _
+             (substitute* "spec/source_location_spec.rb"
+               (("time = Time.now") "skip"))
+             #t)))))
+    (propagated-inputs
+      `(("ruby-interception" ,ruby-interception)
+        ("ruby-pry" ,ruby-pry)))
+    (native-inputs
+     `(("ruby-rspec" ,ruby-rspec)
+       ("ruby-pry-stack-explorer" ,ruby-pry-stack-explorer)))
+    (synopsis
+      "Allows you to wrap code to open a pry session at any unhandled exceptions")
+    (description
+      "Allows you to wrap code in Pry::rescue{ } to open a pry session at any
+unhandled exceptions")
+    (home-page
+      "https://github.com/ConradIrwin/pry-rescue")
+    (license license:expat)))