diff mbox series

[bug#54872,3/5] gnu: python-vedo: Honor #:tests? flag.

Message ID 20220412012143.30573-4-paul@apatience.com
State Accepted
Headers show
Series gnu: python-vedo: Update to 2022.2.0 and sanity-check failures. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 12, 2022, 1:22 a.m. UTC
* gnu/packages/python-science.scm (python-vedo)[arguments]: Adjust
custom 'check phase to honor the #:tests? flag. Also remove its trailing
boolean.
---
 gnu/packages/python-science.scm | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

--
2.35.1
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 07d713e013..4538904b68 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -876,15 +876,15 @@  (define-public python-vedo
          (add-after 'build 'mpi-setup
            ,%openmpi-setup)
          (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (setenv "HOME" (getcwd))
-             (add-installed-pythonpath inputs outputs)
-             (with-directory-excursion "tests"
-               (for-each (lambda (dir)
-                           (with-directory-excursion dir
-                             (invoke "./run_all.sh")))
-                         '("common" "dolfin")))
-             #t)))))
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (setenv "HOME" (getcwd))
+               (add-installed-pythonpath inputs outputs)
+               (with-directory-excursion "tests"
+                 (for-each (lambda (dir)
+                             (with-directory-excursion dir
+                               (invoke "./run_all.sh")))
+                           '("common" "dolfin")))))))))
     (inputs        ; for the check phase
      `(("dolfin" ,fenics)
        ("pkgconfig" ,python-pkgconfig)