diff mbox series

[bug#54871,2/5] gnu: fenics: Honor #:tests? flag.

Message ID 20220412012143.30573-3-paul@apatience.com
State Accepted
Headers show
Series gnu: python-vedo: Update to 2022.2.0 and sanity-check failures. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 12, 2022, 1:22 a.m. UTC
* gnu/packages/simulation.scm (fenics)[arguments]: Adjust custom 'check
phase to honor the #:tests? flag.
---
 gnu/packages/simulation.scm | 23 ++++++++++++-----------
 1 file changed, 12 insertions(+), 11 deletions(-)

--
2.35.1
diff mbox series

Patch

diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index aebb6be15e..3260841608 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -660,17 +660,18 @@  (define-public fenics
              ;; Restrict OpenBLAS to MPI-only in preference to MPI+OpenMP.
              (setenv "OPENBLAS_NUM_THREADS" "1")))
          (replace 'check
-           (lambda _
-             (with-directory-excursion "test"
-               ;; Note: The test test_snes_set_from_options() in the file
-               ;; unit/nls/test_PETScSNES_solver.py fails and is ignored.
-               ;; Limit the number of jobs to 3 as 500 MiB of memory is used
-               ;; per process.
-               (invoke "mpirun" "-np" (number->string
-                                       (min 3 (parallel-job-count)))
-                       "python" "-B" "-m"
-                       "pytest" "unit" "--ignore"
-                       "unit/nls/test_PETScSNES_solver.py"))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (with-directory-excursion "test"
+                 ;; Note: The test test_snes_set_from_options() in the file
+                 ;; unit/nls/test_PETScSNES_solver.py fails and is ignored.
+                 ;; Limit the number of jobs to 3 as 500 MiB of memory is used
+                 ;; per process.
+                 (invoke "mpirun" "-np" (number->string
+                                         (min 3 (parallel-job-count)))
+                         "python" "-B" "-m"
+                         "pytest" "unit" "--ignore"
+                         "unit/nls/test_PETScSNES_solver.py")))))
          (add-after 'install 'install-demo-files
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((demos (string-append