diff mbox series

[bug#54394,core-updates,09/12] gnu: sed-mesboot0: Remove package.

Message ID 20220314225712.19869-9-samplet@ngyro.com
State Accepted
Headers show
Series Remove old GNU utilities from early bootstrap | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Timothy Sample March 14, 2022, 10:57 p.m. UTC
* gnu/packages/commencement.scm (sed-mesboot0): Remove variable.
(%boot-tcc-inputs): Remove 'sed-mesboot0'.
---
 gnu/packages/commencement.scm | 44 -----------------------------------
 1 file changed, 44 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index d0bac512a3..49b7defffb 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -881,54 +881,10 @@  (define patch-mesboot
          ;; FIXME: no compressing gzip yet
          (delete 'compress-documentation))))))
 
-(define sed-mesboot0
-  ;; The initial sed.
-  (package
-    (inherit sed)
-    (name "sed-mesboot0")
-    (version "1.18")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnu/sed/sed-"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "1hyv7i82jd0q18xcql51ylc8jwadp3gb3irgcqlis3v61p35jsv2"))))
-    (supported-systems '("i686-linux" "x86_64-linux"))
-    (inputs '())
-    (propagated-inputs '())
-    (native-inputs (%boot-tcc0-inputs))
-    (arguments
-     `(#:implicit-inputs? #f
-       #:guile ,%bootstrap-guile
-       #:parallel-build? #f
-       #:configure-flags '("CC=tcc")
-       #:make-flags '("CC=tcc" "extra_objs=" "DEFS=-D HAVE_BCOPY")
-       #:strip-binaries? #f             ; no strip yet
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'scripted-patch
-           (lambda _
-             (let* ((out (assoc-ref %outputs "out"))
-                    (bash (assoc-ref %build-inputs "bash"))
-                    (shell (string-append bash "/bin/bash")))
-               (substitute* "configure"
-                 (("/bin/sh") shell)))))
-         (replace 'check
-           (lambda _
-             (invoke "./sed" "--version")))
-         (replace 'install
-           (lambda _
-             (let* ((out (assoc-ref %outputs "out"))
-                    (bin (string-append out "/bin")))
-               (install-file "sed" bin)))))))))
-
 (define (%boot-tcc-inputs)
   `(("bash" ,bash-mesboot0)
     ("gzip" ,gzip-mesboot)
     ("patch" ,patch-mesboot)
-    ("sed" ,sed-mesboot0)
-    ;; Place lower than sed so we don't override it.
     ("gash-utils" ,gash-utils-boot)
     ("tcc" ,tcc-boot)
     ,@(alist-delete "tcc" (%boot-tcc0-inputs))))