diff mbox series

[bug#54394,core-updates,06/12] gnu: gash: Update to 0.3.0.

Message ID 20220314225712.19869-6-samplet@ngyro.com
State Accepted
Headers show
Series Remove old GNU utilities from early bootstrap | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Timothy Sample March 14, 2022, 10:57 p.m. UTC
* gnu/packages/shells.scm (gash): Update to 0.3.0.
[source]: Remove Guile 3.0 snippet.
[arguments]: Delete arguments.
* gnu/packages/commencement.scm (gash-boot)[source]: Do not remove
the Guile 3.0 snippet (it no longer exists).
---
 gnu/packages/commencement.scm |  3 ---
 gnu/packages/shells.scm       | 14 ++------------
 2 files changed, 2 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 084921781d..e63c0b3437 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -143,9 +143,6 @@  (define gash-boot
   (package
     (inherit gash)
     (name "gash-boot")
-    (source (origin
-              (inherit (package-source gash))
-              (snippet #f)))            ;discard snippet for Guile 3.0 support
     (arguments
      `(#:implicit-inputs? #f
        #:tests? #f
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 9bd7ec291c..d46a6549b8 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -870,29 +870,19 @@  (define-public oil
 (define-public gash
   (package
     (name "gash")
-    (version "0.2.0")
+    (version "0.3.0")
     (source
      (origin (method url-fetch)
              (uri (string-append "mirror://savannah/gash/gash-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "13m0yz5h9nj3x40mr6wr5xcpq1lscndfwcicw3skrz801025hhgf"))
-             (modules '((guix build utils)))
-             (snippet
-              '(begin
-                 ;; Allow builds with Guile 3.0.
-                 (substitute* "configure"
-                   (("search=\"2\\.2 2\\.0\"")
-                    "search=\"3.0 2.2 2.0\""))
-                 #t))))
+               "1af2jz4a6rzsshi379wzw4b8d04zvfamdhfzip2pgmk821lyqsjl"))))
     (build-system gnu-build-system)
     (native-inputs
      (list pkg-config))
     (inputs
      (list guile-3.0))
-    (arguments
-     '(#:make-flags '("XFAIL_TESTS=tests/redirects.org")))
     (home-page "https://savannah.nongnu.org/projects/gash/")
     (synopsis "POSIX-compatible shell written in Guile Scheme")
     (description "Gash is a POSIX-compatible shell written in Guile