diff mbox series

[bug#52696,v2,05/11] gnu: python-pynndescent: Update to 0.5.5.

Message ID 20220114200927.165685-5-monego@posteo.net
State Accepted
Headers show
Series [bug#52696,v2,01/11] gnu: python-anyqt: Update to 0.0.13. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Jan. 14, 2022, 8:09 p.m. UTC
* gnu/packages/machine-learning.scm (python-pynndescent): Update to 0.5.5.
[arguments]<#:phases>: Override 'check phase.
[native-inputs]: Remove python-nose. Add python-pytest.
---
 gnu/packages/machine-learning.scm | 14 +++++++++++---
 1 file changed, 11 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 9de0d49e60..56dcc9baf2 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1210,16 +1210,24 @@  for scientific computing and data science (e.g. BLAS and OpenMP).")
 (define-public python-pynndescent
   (package
     (name "python-pynndescent")
-    (version "0.5.2")
+    (version "0.5.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pynndescent" version))
        (sha256
-        (base32 "0w87c2v0li2rdbx6qfc2lb6y6bxpdy3jwfgzfs1kcr4d1chj5zfr"))))
+        (base32 "10pqqqc3jkpw03cyzy04slxmpgyhqnlgbyk0c1cv7kqr5d0zhzbs"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest" "--pyargs" "pynndescent")))))))
     (native-inputs
-     (list python-nose))
+     (list python-pytest))
     (propagated-inputs
      (list python-joblib python-llvmlite python-numba python-scikit-learn
            python-scipy))