diff mbox series

[bug#52696,v2,03/11] gnu: Add python-pytest-pydocstyle.

Message ID 20220114200927.165685-3-monego@posteo.net
State Accepted
Headers show
Series [bug#52696,v2,01/11] gnu: python-anyqt: Update to 0.0.13. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Jan. 14, 2022, 8:09 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-pydocstyle): New variable.
---
 gnu/packages/python-check.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 6d8e3560d9..687750f423 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -686,6 +686,31 @@  framework and makes it easy to undo any monkey patching.  The fixtures are:
 in Pytest.")
     (license license:bsd-3)))
 
+(define-public python-pytest-pydocstyle
+  (package
+    (name "python-pytest-pydocstyle")
+    (version "2.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/henry0312/pytest-pydocstyle")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0w6fivz4nb4b70wzmi5sk17qs9pd05rnh03fmch6v00r3dmfpk39"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; test requires the package itself
+    (propagated-inputs
+     `(("python-pydocstyle" ,python-pydocstyle)
+       ("python-pytest" ,python-pytest))) ; apparently required
+    (home-page "https://github.com/henry0312/pytest-pydocstyle")
+    (synopsis "Pytest plugin to run @command{pydocstyle}")
+    (description "This package provides a Pytest plugin to run
+@command{pydocstyle}.")
+    (license license:expat)))
+
 (define-public python-covdefaults
   (package
     (name "python-covdefaults")