diff mbox series

[bug#50505,v3,10/12] gnu: Add python-mapbox-earcut.

Message ID 20220101235155.5754-11-daniel.meissner-i4k@ruhr-uni-bochum.de
State New
Headers show
Series Add python-manim and its missing dependencies | expand

Commit Message

Daniel Meißner Jan. 1, 2022, 11:51 p.m. UTC
* gnu/packages/python-science.scm (python-mapbox-earcut): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eee2fc0077..5e43b0ca03 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19754,6 +19754,32 @@  (define-public python-moderngl-window
 shaders and objects/scenes.")
    (license license:expat)))
 
+(define-public python-mapbox-earcut
+  (package
+    (name "python-mapbox-earcut")
+    (version "0.12.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mapbox_earcut" version))
+       (sha256
+        (base32
+         "0ly48lijgd9inq07x42pfp9c24fn16vn9axpmfwqrkn979krbnah"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-numpy))
+    (native-inputs
+     (list python-pytest python-wheel python-setuptools-scm cmake))
+    (home-page
+     "https://github.com/skogler/mapbox_earcut_python")
+    (synopsis
+     "Python bindings for the Mapbox Earcut C++ polygon triangulation library")
+    (description
+     "The Mapbox Earcut library is a header-only C++ library which provides a
+fast and robust triangulation of 2D polygons.  This package provides Python
+bindings for this library.")
+    (license license:isc)))
+
 (define-public python-screeninfo
   (package
    (name "python-screeninfo")