diff mbox series

[bug#50505,v3,11/12] gnu: Add python-screeninfo-0.6.

Message ID 20220101235155.5754-12-daniel.meissner-i4k@ruhr-uni-bochum.de
State New
Headers show
Series Add python-manim and its missing dependencies | expand

Commit Message

Daniel Meißner Jan. 1, 2022, 11:51 p.m. UTC
*  (python-screeninfo-0.6): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++----
 1 file changed, 15 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5e43b0ca03..640edabd23 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19780,19 +19780,19 @@  (define-public python-mapbox-earcut
 bindings for this library.")
     (license license:isc)))
 
-(define-public python-screeninfo
+(define-public python-screeninfo-0.6
   (package
    (name "python-screeninfo")
-   (version "0.7")
+   (version "0.6.7")
    (source
     (origin
      (method url-fetch)
      (uri (pypi-uri "screeninfo" version))
      (sha256
       (base32
-       "007m7sqv30qak56885dxbijksrg2hd121hfpvg2llm734wspra8j"))))
+       "1jv9m9xhl7zr2hzfx0w5zyw9pajn4b4zpln4rdl3zni9lcfaqjqw"))))
    (build-system python-build-system)
-   (native-inputs `(("python-pytest" ,python-pytest)))
+   (native-inputs (list python-pytest))
    (home-page "https://github.com/rr-/screeninfo")
    (synopsis
     "Obtain information about physical screens")
@@ -19802,6 +19802,17 @@  (define-public python-screeninfo
 etc.")
    (license (list license:expat license:bsd-3))))
 
+(define-public python-screeninfo
+  (package/inherit python-screeninfo-0.6
+    (version "0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "screeninfo" version))
+       (sha256
+        (base32
+         "007m7sqv30qak56885dxbijksrg2hd121hfpvg2llm734wspra8j"))))))
+
 (define-public python-rencode
   (package
    (name "python-rencode")