diff mbox series

[bug#50505,v3,04/12] gnu: Add python-moderngl.

Message ID 20220101235155.5754-5-daniel.meissner-i4k@ruhr-uni-bochum.de
State New
Headers show
Series Add python-manim and its missing dependencies | expand

Commit Message

Daniel Meißner Jan. 1, 2022, 11:51 p.m. UTC
* gnu/packages/python-xyz.scm (python-moderngl): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Liliana Marie Prikler Jan. 2, 2022, 12:33 a.m. UTC | #1
Am Sonntag, dem 02.01.2022 um 00:51 +0100 schrieb Daniel Meißner:
> +    (description "ModernGL is a python wrapper over OpenGL 3.3+ core
> that
> +simplifies the creation of simple graphics applications like
> scientific
> +simulations, games or user interfaces.  Usually, acquiring in-depth
> knowledge
> +of OpenGL requires a steep learning curve.  In contrast, ModernGL is
> easy to
> +learn and use, moreover it is capable of rendering with high
> performance and
> +quality, with less code written.  The majority of the moderngl code
> base is
> +also written in C++ for high performance.")
The first sentence is enough, we don't need ads :)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d8e6fa070e..21cf780338 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19608,6 +19608,31 @@  (define-public python-glcontext
 implementation for ModernGL on multiple platforms.")
    (license license:expat)))
 
+(define-public python-moderngl
+  (package
+    (name "python-moderngl")
+    (version "5.6.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "moderngl" version))
+       (sha256
+        (base32
+         "1ysinnyr3rkdisbihdrn1623l3rw45nx8p2j31dgffsykxah8vcc"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-glcontext))
+    (home-page "https://github.com/moderngl/moderngl")
+    (synopsis "Python wrapper for OpenGL")
+    (description "ModernGL is a python wrapper over OpenGL 3.3+ core that
+simplifies the creation of simple graphics applications like scientific
+simulations, games or user interfaces.  Usually, acquiring in-depth knowledge
+of OpenGL requires a steep learning curve.  In contrast, ModernGL is easy to
+learn and use, moreover it is capable of rendering with high performance and
+quality, with less code written.  The majority of the moderngl code base is
+also written in C++ for high performance.")
+    (license license:expat)))
+
 (define-public python-rencode
   (package
    (name "python-rencode")