diff mbox series

[bug#50018,v4,09/12] gnu: Remove python2-celery.

Message ID 20211219002917.119449-9-monego@posteo.net
State Accepted
Headers show
Series [bug#50018,v4,01/12] gnu: Add python-click-repl. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Dec. 19, 2021, 12:29 a.m. UTC
* gnu/packages/python-xyz.scm (python2-celery): Remove variable.
(python-celery)[properties]: Remove.
---
 gnu/packages/python-xyz.scm | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 870685211b..0b4f1d3719 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14085,16 +14085,7 @@  supports scheduling as well.  The execution units, called tasks, are executed
 concurrently on a single or more worker servers using multiprocessing,
 Eventlet, or gevent.  Tasks can execute asynchronously (in the background) or
 synchronously (wait until ready).")
-    (license license:bsd-3)
-    (properties `((python2-variant . ,(delay python2-celery))))))
-
-(define-public python2-celery
-  (let ((celery (package-with-python2
-                 (strip-python2-variant python-celery))))
-    (package/inherit celery
-      (native-inputs `(("python2-unittest2" ,python2-unittest2)
-                       ("python2-mock" ,python2-mock)
-                       ,@(package-native-inputs celery))))))
+    (license license:bsd-3)))
 
 (define-public python-translitcodec
   (package