diff mbox series

[bug#50018,v4,10/12] gnu: Remove python2-kombu.

Message ID 20211219002917.119449-10-monego@posteo.net
State Accepted
Headers show
Series [bug#50018,v4,01/12] gnu: Add python-click-repl. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Dec. 19, 2021, 12:29 a.m. UTC
* gnu/packages/python-xyz.scm (python2-kombu): Remove variable.
(python-kombu)[properties]: Remove.
---
 gnu/packages/python-xyz.scm | 14 +-------------
 1 file changed, 1 insertion(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b4f1d3719..b673f01211 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13988,19 +13988,7 @@  and also provide proven and tested solutions to common messaging problems.
 AMQP is the Advanced Message Queuing Protocol, an open standard protocol for
 message orientation, queuing, routing, reliability and security, for which the
 RabbitMQ messaging server is the most popular implementation.")
-    (license license:bsd-3)
-    (properties `((python2-variant . ,(delay python2-kombu))))))
-
-(define-public python2-kombu
-  (let ((kombu (package-with-python2
-                (strip-python2-variant python-kombu))))
-    (package/inherit kombu
-      (arguments `(;; FIXME: 'TestTransport.test_del_sync' fails on python2.
-                   ;; It works fine on the python3 variant.
-                   #:tests? #f
-                   ,@(package-arguments kombu)))
-      (native-inputs `(("python2-unittest2" ,python2-unittest2)
-                ,@(package-native-inputs kombu))))))
+    (license license:bsd-3)))
 
 (define-public python-billiard
   (package