diff mbox series

[bug#50018,v4,08/12] gnu: python-celery: Enable tests.

Message ID 20211219002917.119449-8-monego@posteo.net
State Accepted
Headers show
Series [bug#50018,v4,01/12] gnu: Add python-click-repl. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Dec. 19, 2021, 12:29 a.m. UTC
* gnu/packages/python-xyz.scm (python-celery)[arguments]: Remove
'patch-requirements phase. Remove #:tests?. Override 'check phase.
[native-inputs]: Add python-flaky, python-iniconfig, python-moto,
python-msgpack, python-pytest-celery, python-pytest-subtests,
python-pytest-timeout, python-toml.
---
 gnu/packages/python-xyz.scm | 26 +++++++++++++++-----------
 1 file changed, 15 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 00a834a33a..870685211b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14056,19 +14056,23 @@  Python 2.4 and 2.5, and will draw its fixes/improvements from python-trunk.")
         (base32 "1c6lw31i3v81fyj4yn37lbvv70xdgb389iccirzyjr992vlkv6ld"))))
     (build-system python-build-system)
     (arguments
-     '(;; TODO The tests fail with Python 3.7
-       ;; https://github.com/celery/celery/issues/4849
-       #:tests? #f
-       #:phases
+     '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-requirements
+         (add-after 'unpack 'delete-integration-tests
            (lambda _
-             (substitute* "requirements/test.txt"
-               (("pytest>=3\\.0,<3\\.3")
-                "pytest>=3.0"))
-             #t)))))
-    (native-inputs
-     (list python-case python-pytest))
+             (delete-file-recursively "t/integration"))) ; hangs tests
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest" "t" "-k"
+                       (string-append   ; AssertionErrors
+                        "not test_check_privileges_no_fchown"
+                        " and not test_all_reqs_enabled_in_tests"))))))))
+    (native-inputs
+     (list python-case python-flaky python-iniconfig python-moto
+           python-msgpack python-pytest python-pytest-celery
+           python-pytest-subtests python-pytest-timeout python-toml))
     (propagated-inputs
      (list python-billiard python-boto3 python-click python-click-didyoumean
            python-click-plugins python-click-repl python-cryptography