diff mbox series

[bug#51938,core-updates-frozen,07/22] gnu: gedit: Build with Meson 0.59.

Message ID 20211118070635.8259-7-samplet@ngyro.com
State Accepted
Headers show
Series Fixes for GNOME packages | expand

Commit Message

Timothy Sample Nov. 18, 2021, 7:06 a.m. UTC
See <https://github.com/mesonbuild/meson/issues/9441>.

* gnu/packages/gnome.scm (gedit)[arguments]: Use meson-0.59.
---
 gnu/packages/gnome.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 645a87f805..a1811ca467 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7370,7 +7370,8 @@  (define-public gedit
                 "149ngl9qw6h59546lir1pa7hvw23ppsnqlj9mfqphmmn5jl99qsm"))))
     (build-system meson-build-system)
     (arguments
-     `(#:glib-or-gtk? #t
+     `(#:meson ,meson-0.59         ;positional arguments error with meson 0.60
+       #:glib-or-gtk? #t
        #:configure-flags
        ;; Otherwise, the RUNPATH will lack the final path component.
        (list (string-append "-Dc_link_args=-Wl,-rpath="