diff mbox series

[bug#51938,core-updates-frozen,01/23] gnu: eog: Build with Meson 0.59.

Message ID 20211118070323.8061-1-samplet@ngyro.com
State Accepted
Headers show
Series Fixes for GNOME packages | expand

Commit Message

Timothy Sample Nov. 18, 2021, 7:03 a.m. UTC
See <https://github.com/mesonbuild/meson/issues/9441>.

* gnu/packages/gnome.scm (eog)[arguments]: Use meson-0.59.
---
 gnu/packages/gnome.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8677a6849d..594e07becc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6470,7 +6470,8 @@  (define-public eog
               "0ddjwcd77nw0rxb5x5bz5hd671m8gya9827p8rsnb58x103kpai8"))))
    (build-system meson-build-system)
    (arguments
-    `(#:configure-flags
+    `(#:meson ,meson-0.59         ;positional arguments error with meson 0.60
+      #:configure-flags
       ;; Otherwise, the RUNPATH will lack the final 'eog' path component.
       (list (string-append "-Dc_link_args=-Wl,-rpath="
                            (assoc-ref %outputs "out") "/lib/eog"))