diff mbox series

[bug#51938,core-updates-frozen,03/22] gnu: gnome-weather: Build with Meson 0.59.

Message ID 20211118070635.8259-3-samplet@ngyro.com
State Accepted
Headers show
Series Fixes for GNOME packages | expand

Commit Message

Timothy Sample Nov. 18, 2021, 7:06 a.m. UTC
See <https://github.com/mesonbuild/meson/issues/9441>.

* gnu/packages/gnome.scm (gnome-weather)[arguments]: Use meson-0.59.
---
 gnu/packages/gnome.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d432653e69..f9985ff429 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9369,7 +9369,8 @@  (define-public gnome-weather
       ("libgweather" ,libgweather)
       ("libhandy" ,libhandy)))
    (arguments
-    `(#:glib-or-gtk? #t
+    `(#:meson ,meson-0.59         ;positional arguments error with meson 0.60
+      #:glib-or-gtk? #t
       #:phases
       ,#~(modify-phases %standard-phases
            (add-after 'unpack 'fix-service-file