diff mbox series

[bug#51314,v2,20/24] gnu: python-wrapt: Enable tests.

Message ID 20211113200230.192559-20-monego@posteo.net
State New
Headers show
Series [bug#51314,v2,01/24] gnu: Add python-sarge. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Nov. 13, 2021, 8:02 p.m. UTC
* gnu/packages/python-xyz.scm (python-wrapt)[source]: Fetch from GitHub.
[arguments]<#:phases>: Override 'check phase.
---
 gnu/packages/python-xyz.scm | 21 ++++++++++++++-------
 1 file changed, 14 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 402053e96f..8fcc9583ab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10841,16 +10841,23 @@  Supported netlink families and protocols include:
     (version "1.13.3")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "wrapt" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/GrahamDumpleton/wrapt")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "11f13zqgbql26g5bkfkqalckcdlz394g6dhx4y16cvk873a9rshz"))))
+        (base32 "05d7xs6rvaw9gpcvsvk7ckxiax1nrxcpv41vrqkkl7zq967d9bcj"))))
     (build-system python-build-system)
     (arguments
-     ;; Tests are not included in the tarball, they are only available in the
-     ;; git repository.
-     `(#:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "unittest" "discover"
+                       "-s" "tests")))))))
     (home-page "https://github.com/GrahamDumpleton/wrapt")
     (synopsis "Module for decorators, wrappers and monkey patching")
     (description