diff mbox series

[bug#51314,v2,12/24] gnu: python-feedparser: Enable tests.

Message ID 20211113200230.192559-12-monego@posteo.net
State New
Headers show
Series [bug#51314,v2,01/24] gnu: Add python-sarge. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Nov. 13, 2021, 8:02 p.m. UTC
* gnu/packages/web.scm (python-feedparser)[arguments]: Remove
 #:tests?. Override 'check phase.
---
 gnu/packages/web.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b3f5180d79..aea397ee13 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4777,7 +4777,13 @@  their web site.")
     (propagated-inputs
      `(("python-sgmllib3k" ,python-sgmllib3k)))
     (arguments
-     '(#:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "tests/runtests.py")))))))
     (home-page
      "https://github.com/kurtmckee/feedparser")
     (synopsis "Parse feeds in Python")