diff mbox series

[bug#51396,v2,8/8] gnu: python-moto: Honor #:tests? flag.

Message ID 20211105015836.1046845-8-monego@posteo.net
State Accepted
Headers show
Series None | expand

Commit Message

Vinicius Monego Nov. 5, 2021, 1:58 a.m. UTC
* gnu/packages/python-xyz.scm (python-moto)[arguments]: Adjust custom 'check
phase to honor the #:tests? flag.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++--------------
 1 file changed, 15 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 528e3b025a..0ef836e0bc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13116,20 +13116,21 @@  text.")
                (substitute* (find-files "tests" "\\.py$")
                  (("#!/bin/bash") (string-append "#!" bash-exec))))))
          (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             (invoke "pytest" "-vv" "-m" "not network" "-k"
-                     (string-append
-                      ;; These tests require Docker.
-                      "not test_terminate_job"
-                      " and not test_invoke_function_from_sqs_exception"
-                      " and not test_rotate_secret_lambda_invocations"
-                      ;; These tests also require the network.
-                      " and not test_put_record_batch_http_destination"
-                      " and not test_put_record_http_destination"
-                      " and not test_dependencies"
-                      " and not test_cancel_running_job"
-                      " and not test_container_overrides")))))))
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "pytest" "-vv" "-m" "not network" "-k"
+                       (string-append
+                        ;; These tests require Docker.
+                        "not test_terminate_job"
+                        " and not test_invoke_function_from_sqs_exception"
+                        " and not test_rotate_secret_lambda_invocations"
+                        ;; These tests also require the network.
+                        " and not test_put_record_batch_http_destination"
+                        " and not test_put_record_http_destination"
+                        " and not test_dependencies"
+                        " and not test_cancel_running_job"
+                        " and not test_container_overrides"))))))))
     (native-inputs
      `(("python-flask" ,python-flask)
        ("python-flask-cors" ,python-flask-cors)