diff mbox series

[bug#51396,v2,4/8] gnu: python-s3transfer: Update to 0.5.0.

Message ID 20211105015836.1046845-4-monego@posteo.net
State Accepted
Headers show
Series None | expand

Commit Message

Vinicius Monego Nov. 5, 2021, 1:58 a.m. UTC
* gnu/packages/python-web.scm (python-s3transfer): Update to 0.5.0.
[arguments]<#:phases>: Remove 'patch phase because the issue was fixed
upstream. Don't return #t in custom 'check phase.
---
 gnu/packages/python-web.scm | 16 +++-------------
 1 file changed, 3 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 66411173d0..2953198a08 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3404,32 +3404,22 @@  Betamax that may possibly end up in the main package.")
 (define-public python-s3transfer
   (package
     (name "python-s3transfer")
-    (version "0.3.3")
+    (version "0.5.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "s3transfer" version))
               (sha256
                (base32
-                "1nzp5kwmy9669334shcz9ipg89jgpdqhrmbkgdg18r7wmvi3f6lj"))))
+                "0k6sc956yrrv9b4laa0r79jhxajpyxr21jcd1ka8m1n53lz85vah"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch
-           (lambda _
-             ;; There's a small issue with one test with Python 3.8, this
-             ;; change has been suggested upstream:
-             ;; https://github.com/boto/s3transfer/pull/164
-             (substitute* "tests/unit/test_s3transfer.py"
-               (("super\\(FailedDownloadParts, self\\)\\.submit\\(function\\)")
-                "futures.Future()"))
-             #t))
          (replace 'check
            (lambda _
              ;; Some of the 'integration' tests require network access or
              ;; login credentials.
-             (invoke "nosetests" "--exclude=integration")
-             #t)))))
+             (invoke "nosetests" "--exclude=integration"))))))
     (native-inputs
      `(("python-docutils" ,python-docutils)
        ("python-mock" ,python-mock)