diff mbox series

[bug#51396,v2,5/8] gnu: python-s3transfer: Honor #:tests? flag.

Message ID 20211105015836.1046845-5-monego@posteo.net
State Accepted
Headers show
Series None | expand

Commit Message

Vinicius Monego Nov. 5, 2021, 1:58 a.m. UTC
* gnu/packages/python-web.scm (python-s3transfer)[arguments]: Adjust custom
'check phase to honor the #:tests? flag.
---
 gnu/packages/python-web.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2953198a08..9d1ae458d3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3416,10 +3416,11 @@  Betamax that may possibly end up in the main package.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             ;; Some of the 'integration' tests require network access or
-             ;; login credentials.
-             (invoke "nosetests" "--exclude=integration"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; Some of the 'integration' tests require network access or
+               ;; login credentials.
+               (invoke "nosetests" "--exclude=integration")))))))
     (native-inputs
      `(("python-docutils" ,python-docutils)
        ("python-mock" ,python-mock)