diff mbox series

[bug#51314,17/29] gnu: python-feedparser: Enable tests.

Message ID 20211021040200.241873-13-monego@posteo.net
State New
Headers show
Series Add Octoprint (web UI for 3d printers). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Oct. 21, 2021, 4:01 a.m. UTC
* gnu/packages/web.scm (python-feedparser)[arguments]: Remove
#:tests?. Override 'check phase.
---
 gnu/packages/web.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6a24cc8212..5afc6e8cec 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4775,7 +4775,13 @@  their web site.")
          "0qcnkyjjfj5gg5rhd1j4zzlqx5h34bma18zwgj68q95b0l543q2w"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "tests/runtests.py")))))))
     (propagated-inputs
      `(("python-sgmllib3k" ,python-sgmllib3k)))
     (home-page